Nebula CC Upgrade Notification - 2026-07-27 00:15 ~ 02:00

Scheduled for Jul 27, 00:15 - 02:00 UTC

Update

The system will temporarily unavailable due to the upgrading.

Reason:
Nebula Control Center will be upgrading to release 20.10.

Started from:
2026-07-27 00:15 (UTC+0)

Completed:
2026-07-27 02:00 (UTC+0)

Affected scope & Risk:

All users will be force logout from Nebula Control Center and inaccessible during the progress.

Note:
1. During this period, NCAS (Nebula Cloud Authentication Server) will be refreshed, authentication service will be temporarily unavailable.
2. This maintenance event does not affect Nebula devices and their local network services.
Posted Jul 16, 2026 - 06:43 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Jun 23, 2026 - 08:40 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Jun 23, 2026 - 08:39 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Jun 08, 2026 - 15:05 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Jun 08, 2026 - 08:41 UTC

Scheduled

The system will temporarily unavailable due to the upgrading.

Reason:
Nebula Control Center will be upgrading to release 20.10.

Started from:
2026-07-27 00:15 (UTC+0)

Completed:
2026-07-27 01:00 (UTC+0)

Affected scope & Risk:

All users will be force logout from Nebula Control Center and inaccessible during the progress.

Note: This maintenance event does not affect Nebula devices and their local network services.
Posted Jun 02, 2026 - 07:06 UTC
This scheduled maintenance affects: Nebula Control Center (Nebula Control Center platform issue, License related issue, Cloud authentication service, Nebula OpenAPI, Alert services).